summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorroot <root@fedora-arm.domain.avtechpulse.com>1999-12-31 19:49:19 -0500
committerroot <root@fedora-arm.domain.avtechpulse.com>1999-12-31 19:49:19 -0500
commit3702b14f594c86af91e063e8b1403e7bfd982bfe (patch)
treecaec2c51f56121cd201141003cfb851f9108303b /CMakeLists.txt
parentdcbb634ee0093999b5316a579728969e8bdb1852 (diff)
initial parser re-implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56f5ee4..882db13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,16 +1,23 @@
cmake_minimum_required(VERSION 2.8)
-
project(Instrument)
-# add the binary tree to the search path for include files
-include_directories("${PROJECT_BINARY_DIR}")
-
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
find_package(Glib)
find_package(GIO)
include_directories(${GLIB_PKG_INCLUDE_DIRS})
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g")
-add_executable(instr-daemon instr-daemon.c signalobject.c response.c i2c.c lcd.c)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -Wall")
+add_executable(instr-daemon instr-daemon.c
+ signalobject.c
+ response.c
+ parser.c
+ error_utils.c
+ device-functions.c
+ string_utils.c
+ globals.c
+ i2c.c
+ lcd.c
+ dummy_functions.c
+)
add_executable(instr-client instr-client.c)
target_link_libraries(instr-daemon gio-2.0 gobject-2.0 glib-2.0)