summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Chudobiak <mjc@avtechpulse.com>2012-07-20 08:24:35 -0400
committerMichael J. Chudobiak <mjc@avtechpulse.com>2012-07-20 08:24:35 -0400
commita59acebb93a89fd560b947333b1d37d1d177ce10 (patch)
tree1d91037d8bc05bf216440a87e4160c55c32c2d39 /CMakeLists.txt
parent36fa03dc7b96994a86db9fa7a51e8dd654c27b14 (diff)
added version info
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f63209..95d9ddc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,18 @@
cmake_minimum_required(VERSION 2.8)
-project(glib-sock-serv)
+
+project(Instrument)
+set(FW_VERSION 5.00)
+
+# configure a header file to pass some of the CMake settings
+# to the source code
+configure_file (
+ "${PROJECT_SOURCE_DIR}/version.h.in"
+ "${PROJECT_BINARY_DIR}/version.h"
+)
+
+# add the binary tree to the search path for include files
+# so that we will find TutorialConfig.h
+include_directories("${PROJECT_BINARY_DIR}")
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
find_package(Glib)