summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Chudobiak <mjc@avtechpulse.com>2012-07-19 08:41:04 -0400
committerMichael J. Chudobiak <mjc@avtechpulse.com>2012-07-19 08:41:04 -0400
commit299b166ff820e8413f0c34ed5a2e7afac46cd477 (patch)
treeb0b8e1520af740e8a63fd132ebae82326054e12f /CMakeLists.txt
initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..4d7d8e9
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.8)
+project(glib-sock-serv)
+
+set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+find_package(Glib)
+find_package(GIO)
+include_directories(${GLIB_PKG_INCLUDE_DIRS})
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g")
+add_executable(instr-daemon instr-daemon.c signalobject.c response.c)
+add_executable(instr-client instr-client.c)
+
+target_link_libraries(instr-daemon gio-2.0)
+target_link_libraries(instr-client gio-2.0)
+
+