summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7cf0643..c02b3ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,7 @@ project(Instrument)
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
find_package(Glib)
find_package(GIO)
+find_package(Mhash)
include_directories(${GLIB_PKG_INCLUDE_DIRS})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -funsigned-char -Wall")
add_executable(instr-daemon instr-daemon.c
@@ -23,7 +24,7 @@ add_executable(instr-daemon instr-daemon.c
)
add_executable(instr-client instr-client.c)
-target_link_libraries(instr-daemon gio-2.0 gobject-2.0 glib-2.0)
+target_link_libraries(instr-daemon gio-2.0 gobject-2.0 glib-2.0 mhash)
target_link_libraries(instr-client gio-2.0 gobject-2.0 glib-2.0)
INSTALL(TARGETS instr-daemon instr-client